Results 1 to 3 of 3

Thread: Wrapped screw?

  1. #1
    Join Date
    Jan 2018
    Posts
    2

    Wrapped screw?

    We just recently cleaned the screw on one of our machines and it hasn't ran right since. The recovery time, cushion, and max pressure are not holding consistently. They will stay in a certain range for a while, then suddenly shift to a faster recovery and the cushion and max pressures will shoot up. When investigating the cause, I discovered that the barrel profile was quite flat. I think 420-425 tapered up from the feed zone. We are running a 2.8 MFI HDPE. Hold times are about 12 sec and a cooling time of about 25 sec.
    Is it possible that the flat profile and long cycle time has caused the material to fuse to the screw and prevent forward flow of material? What is typically done to remove this plastic from the screw?
    On another note, when we pulled the screw everything measured and looked quite good, except that there was quite a bit of brown staining on the root of the screw. We had to clean this off with scotchbrite pads. Please see enclosed pic. Is this normal? Is there a better way to clean this off? Do I need to use some sort of polishing compound on this?
    Attached Thumbnails Attached Thumbnails 20171227_104747.jpg  

  2. #2
    Join Date
    Jan 2018
    Posts
    3

    Re: Wrapped screw?

    What sort of material are you using with this screw?
    Have you tried asaclean or similar purging compound?

    Also, during your process, are you using a time based cut off?

  3. #3
    Join Date
    Jan 2018
    Posts
    2

    Re: Wrapped screw?

    MooCop,
    99.9% of what we mold is HDPE. The rest is a type of PE.
    We use Ultra Purge at shutdown.

    Our vpt is position dependent.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •