Results 1 to 6 of 6

Thread: Parts sticking to pins

  1. #1
    Join Date
    Jan 2020
    Posts
    14

    Parts sticking to pins

    Hey guys so I canít say an awful lot about it but on a poly job running chiller on the mold I have parts sticking to the pins. The pin witness marks are not prominent and no flash around where the pins are. Iím down half a sec on cycle time to get the press running consistently but I am curious as to what could be causing it. The parts are sticking to just the pins not the cavity and like I said that t shows me no signs as to why itís doing it no prominent witness marks no stress marks from ejection parts are correct sizes and cooling time is within process parameter. I also have the press running consistently by giving more time for parts to fall after second stroke(parts move in and out with the pins until back on second stroke) but I need that half second back and canít figure out where to take it from the cycle

  2. #2
    Join Date
    Nov 2012
    Posts
    117

    Re: Parts sticking to pins

    rule no.1
    Do not touch running proces

  3. #3
    Join Date
    Mar 2020
    Posts
    1

    Re: Parts sticking to pins

    Is this a new problem or has it been an issue from day one?

  4. #4
    Join Date
    Sep 2012
    Location
    Lakewood, WI
    Posts
    92

    Re: Parts sticking to pins

    Ejector pins standing proud causing plastic to be molded around them? I've seen this many times, esp. with light parts and/or sleeve ejection.

  5. #5
    Join Date
    Jan 2020
    Posts
    14

    Re: Parts sticking to pins

    Sorry to take so long to get back I ran at the slower cycle till engineering got in told them the mold was over packed and after they lowered the shot size down all issues disappeared I knew it was an overpack problem but not being allowed to change things on the injection screen makes fixing it a pain in the rear

  6. #6
    Join Date
    Nov 2019
    Posts
    2

    Re: Parts sticking to pins

    Quote Originally Posted by Platt1990 View Post
    Hey guys so I canít say an awful lot about it but on a poly job running chiller on the mold I have parts sticking to the pins. The pin witness marks are not prominent and no flash around where the pins are. Iím down half a sec on cycle time to get the press running consistently but I am curious as to what could be causing it. The parts are sticking to just the pins not the cavity and like I said that t shows me no signs as to why itís doing it no prominent witness marks no stress marks from ejection parts are correct sizes and cooling time is within process parameter. I also have the press running consistently by giving more time for parts to fall after second stroke(parts move in and out with the pins until back on second stroke) but I need that half second back and canít figure out where to take it from the cycle
    So Armoloy Southeast does chrome plating that can be applied anywhere from .00005" - .0003" - depends on what you need. They offer TDC (thin dense chrome), XADC (which is a diamond chrome), and Electrolizing (hard chrome). The XADC is for extreme wear applications in mold components. Both XADC and TDC have great release characteristics and will prevent plastic sticking to mold components. Along with reducing friction and wear, enhanced corrosion resistance, and increased surface hardness.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •